Deployments are slow
Partial Outage
Deployments (US West)Deployments (Southeast Asia)Deployments (EU West)Deployments (US East)
ResolvedLATEST

Deployments are operating normally. The backlog of queued deployments has cleared and deployment times have returned to expected levels.

The root cause was a Google Cloud infrastructure issue beginning around 14:53 UTC that caused elevated errors in our backend services, leading to congestion in our deployment processing pipeline. We temporarily paused new deployments to prevent further backlog buildup while we worked to restore normal operations. The Google Cloud issue has since resolved and our systems have recovered.

We apologize for the disruption. If you continue to experience issues, please contact support at https://station.railway.com.

August 20, 18:20 UTC
Earlier updates
Monitoring

The deployment pause has been lifted and the backlog of queued deployments is clearing. New deployments are being accepted and processing again, though some delays may persist as the queue continues to drain.

We are continuing to monitor the situation and will provide further updates.

August 20, 17:31 UTC
Identified

We have identified that a Google Cloud infrastructure issue is contributing to deployment delays. Our backend services experienced elevated internal errors from Google Cloud beginning around 14:53 UTC, which caused our deployment processing pipeline to become congested. We have made adjustments and it is starting to improve but still delayed. We will provide further updates as the situation develops.

August 20, 17:29 UTC
Identified

We have identified that a Google Cloud infrastructure issue is contributing to deployment delays. Our backend services experienced elevated internal errors from Google Cloud beginning around 14:53 UTC, which caused our deployment processing pipeline to become congested.

We are actively working to mitigate the impact and restore normal deployment throughput. As we do this deployments will be temporarily paused at times and slower. We will provide further updates as the situation develops.

August 20, 16:15 UTC
Identified

We have identified that a Google Cloud infrastructure issue is contributing to deployment delays. Our backend services experienced elevated internal errors from Google Cloud beginning around 14:53 UTC, which caused our deployment processing pipeline to become congested.

We are actively working to mitigate the impact and restore normal deployment throughput. We will provide further updates as the situation develops.

August 20, 15:56 UTC
Investigating

We are aware of an issue causing deployments to queue and take longer than usual to progress. Users may experience delays in deployments starting or completing.

We are actively investigating the root cause and will provide updates as we learn more.

August 20, 15:27 UTC