Edge Network connectivity issues in Singapore
Degraded Performance
Networking — Public (Southeast Asia)
ResolvedLATEST

We have seen consistent recovery and are marking this incident as resolved.

May 4, 20:06 UTC
Earlier updates
Monitoring

Edge routing has recovered in Southeast Asia and we are monitoring the results.

May 4, 19:50 UTC
Investigating

We are aware of an issue affecting edge routing in our Southeast Asia (Singapore) region. Users may experience failed requests or DNS resolution errors when reaching services deployed in this region.

We are actively investigating and will provide updates as we learn more.

May 4, 19:41 UTC