Dashboard slow to load

Dashboard (railway.com)Degraded Performance
Resolved

This incident has been resolved.

March 2, 19:16 UTC
Monitoring

We have deployed a fix for the dashboard slowness and are monitoring to confirm full recovery.

March 2, 19:06 UTC
Identified

We have identified the cause of the dashboard slowness and are working on a fix. Users may continue to experience slower than normal load times while the fix is deployed.

March 2, 18:37 UTC
Investigating

We are aware of slower than normal load times on the dashboard. Users may experience delays when navigating [railway.com](http://railway.com).

We are actively investigating and will provide updates as we learn more.

March 2, 18:18 UTC