Elevated build times for services on Metal Build Environment

Build Machines (Metal), Image Registry (Metal)Degraded Performance
Resolved

This incident has been resolved.

January 14, 21:55 UTC
Monitoring

We implemented a fix and are currently monitoring the result.

January 14, 21:35 UTC
Investigating

We are currently investigating an issue with metal builds. You may turn off "Use Metal Build Environment" in service settings to mitigate this if you are experiencing a delay in builds.

January 14, 20:45 UTC