Logs loading slowly

LogsDegraded Performance
Resolved

This incident has been resolved.

March 13, 17:31 UTC
Identified

We're seeing continued degradation on logs loading time. We are continuing to work on a fix.

March 13, 16:50 UTC
Monitoring

We implemented a fix and are currently monitoring the result.

March 13, 15:59 UTC
Identified

We've confirmed logs are loading with elevated delay. Our team is aware and working on a fix.

March 13, 15:39 UTC
Investigating

We're investigating an issue causing logs not to load.

March 13, 15:25 UTC