We're currently experiencing elevated latency in our EU-West region

EU West (Metal / Amsterdam, Netherlands)Major Outage
Resolved

This incident has been resolved.

March 24, 19:10 UTC
Monitoring

We implemented a fix and are currently monitoring the result.

March 24, 19:05 UTC
Investigating

We are currently investigating this incident.

March 24, 18:54 UTC