Builds are slow in EU West
Degraded Performance
Builds (EU West)
MonitoringLATEST

We are continuing to monitor the situation following our fix. Build times in EU West (Amsterdam) are returning to normal and the queue is clearing.

We will provide a further update shortly.

September 23, 14:52 UTC
Earlier updates
Identified

We have identified the root cause as an issue with our deployment system in EU West that was causing builds to queue and take longer than expected. We are working to resolve this and will provide another update as we make progress.

September 23, 14:13 UTC
Investigating

We have identified a possible issue with our deployment system in EU West that may be causing builds to queue and take longer than expected. We are continuing to investigate and working to resolve the issue.

We will provide another update as we learn more.

September 23, 13:53 UTC
Investigating

We are aware of an issue causing builds to take longer than expected in EU West (Amsterdam). Users in this region may experience builds progressing slowly or taking longer to start.

We are actively investigating and will provide updates as we learn more.

September 23, 13:24 UTC