GitHub operations are being rate-limited. Users may be unable to log-in or add GitHub repos. We are working on resolution for this issue.

GitHubDegraded Performance
Resolved

Our monitors have shown that we have good effect on our changes, although we have improvement, we are still monitoring the impact for all customers.

January 29, 19:15 UTC
Monitoring

We have observed no further GitHub rate limiting in the last 60 minutes and we are reanbling GitHub authentication.

January 29, 18:13 UTC
Identified

We have rolled out additional fixes to improve GitHub callpath resiliency. We are monitoring their effectiveness and will issue an update once we finish monitoring.

January 29, 17:38 UTC
Identified

We have disabled GitHub log in to reduce rate-limit pressure on the system.

January 29, 15:25 UTC
Investigating

GitHub operations are being rate-limited. Users may be unable to log-in or add GitHub repos. We are working on resolution for this issue.

January 29, 15:06 UTC