Degraded Performance in EU West

EU West (Metal / Amsterdam, Netherlands), Build Machines (Metal), Image Registry (Metal)Degraded Performance
Resolved

This incident has been resolved.

March 20, 16:22 UTC
Monitoring

We implemented a fix and are currently monitoring the result.

March 20, 15:22 UTC
Identified

We identified the source of degraded performance in EU West and are continuing to work on a fix for this incident.

March 20, 14:49 UTC
Investigating

We are investigating reports of degraded performance for services in EU West. Some users may experience slow builds, delayed container creation, or elevated response times. Our team is actively investigating.

March 20, 14:12 UTC