Railway - Deployments stuck – Incident details

Deployments stuck

Resolved
Partial outage
Started 8 days agoLasted about 1 hour

Affected

Builds (Railway Metal)

Degraded performance from 10:16 PM to 10:56 PM, Partial outage from 10:56 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

Image Registry (Metal)

Degraded performance from 10:16 PM to 10:56 PM, Partial outage from 10:56 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

Build Machines (Metal)

Degraded performance from 10:16 PM to 10:56 PM, Partial outage from 10:56 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

Deployments (Railway Metal)

Operational from 10:16 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

US West (Metal / California, USA)

Operational from 10:16 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

US East (Metal / Virginia, USA)

Operational from 10:16 PM to 11:35 PM, Degraded performance from 11:35 PM to 11:38 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. New deployments for free, trial and hobby have been re-enabled.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We have identified the root cause and are deploying a fix.

  • Update
    Update

    Hobby, free and trial deploys have been temporarily disabled. We are continuing our investigation into the root issue

  • Investigating
    Investigating

    We are aware of an issue where new builds may appear stuck and fail to complete or progress slowly. Existing running services are not affected. We are actively investigating and working on a fix.