Railway - Temporary Deployment Slowdown – Incident details

Temporary Deployment Slowdown

Resolved
Major outage
Started 2 days agoLasted about 2 hours

Affected

Deployments (Railway Metal)

Operational from 5:41 PM to 6:12 PM, Degraded performance from 6:12 PM to 6:19 PM, Major outage from 6:19 PM to 7:18 PM

US West (Metal / California, USA)

Operational from 5:41 PM to 6:12 PM, Degraded performance from 6:12 PM to 6:19 PM, Major outage from 6:19 PM to 7:18 PM

US East (Metal / Virginia, USA)

Operational from 5:41 PM to 6:12 PM, Degraded performance from 6:12 PM to 6:19 PM, Major outage from 6:19 PM to 7:18 PM

EU West (Metal / Amsterdam, Netherlands)

Operational from 5:41 PM to 6:12 PM, Degraded performance from 6:12 PM to 6:19 PM, Major outage from 6:19 PM to 7:18 PM

Southeast Asia (Metal / SIngapore)

Operational from 5:41 PM to 6:12 PM, Degraded performance from 6:12 PM to 6:19 PM, Major outage from 6:19 PM to 7:18 PM

Deployments (Legacy)

Updates
  • Postmortem
    Postmortem
  • Resolved
    Resolved

    This incident has been resolved. A post-mortem of this incident will be published on https://blog.railway.com.

  • Update
    Update

    All Free and Trial deployments have been re-enabled.

  • Update
    Update

    All Hobby deployments have been re-enabled.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. Pro deployments have been re-enabled.

  • Update
    Update

    We're temporarily pausing all deployments across the platform, including Pro tier, to reduce system load while we resolve an issue with our deployment queue.

  • Update
    Update

    We are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are investigating delayed deployments. Free, Trial, and Hobby deployments are temporarily paused.