Railway - Network control plane outage – Incident details

Network control plane outage

Resolved
Operational
Started about 18 hours agoLasted about 2 hours

Affected

Dashboard (railway.com)

Major outage from 8:49 PM to 9:25 PM, Operational from 9:25 PM to 9:44 PM, Major outage from 9:44 PM to 10:09 PM, Operational from 10:09 PM to 10:27 PM

Deployments (Railway Metal)

Major outage from 8:49 PM to 10:09 PM, Partial outage from 10:09 PM to 10:14 PM, Operational from 10:14 PM to 10:27 PM

US West (Metal / California, USA)

Major outage from 8:49 PM to 10:09 PM, Partial outage from 10:09 PM to 10:14 PM, Operational from 10:14 PM to 10:27 PM

US East (Metal / Virginia, USA)

Major outage from 8:49 PM to 10:09 PM, Partial outage from 10:09 PM to 10:14 PM, Operational from 10:14 PM to 10:27 PM

EU West (Metal / Amsterdam, Netherlands)

Major outage from 8:49 PM to 10:09 PM, Partial outage from 10:09 PM to 10:14 PM, Operational from 10:14 PM to 10:27 PM

Southeast Asia (Metal / SIngapore)

Major outage from 8:49 PM to 10:09 PM, Partial outage from 10:09 PM to 10:14 PM, Operational from 10:14 PM to 10:27 PM

Updates
  • Postmortem
    Postmortem

    The postmortem for this incident can be found here:

    https://blog.railway.com/p/incident-report-oct-15th-2025

  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We implemented a fix and are currently monitoring the result.

    Deployments for all plans have been re-enabled.

  • Monitoring
    Monitoring

    We have enabled deployments for Pro users only.

    Once we confirm stability, we will enable deploys for other plans.

  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    Deployments are paused for all users while we investigate an issue with the network control plane.

    The dashboard may fail to load projects during this time, but all running services are unaffected.