Railway - SSL certificates are failing to issue – Incident details

SSL certificates are failing to issue

Resolved
Degraded performance
Started 5 days agoLasted about 1 hour

Affected

Private Networking

Updates
  • Resolved
    Resolved

    The Google Cloud Public DNS resolver now seems to be resolving domains correctly. We have also switched to an alternate DNS server to mitigate this issue.

  • Identified
    Identified

    We have identified the issue as a failure to resolve domains via Google Cloud Public DNS in Oregon. We query these DNS servers to check for record propagation before issuing certificates. It appears that Public DNS in Oregon is not returning responses for domains. We are switching to an alternate DNS server

  • Investigating
    Investigating
    SSL certificate issuance