Metrics and logs may be delayed or unavailable
Degraded Performance
MetricsLogs
ResolvedLATEST

Metrics and logs have returned healthy for an extended period now. We are marking this incident as resolved.

If you have any questions, https://station.railway.com

June 8, 16:49 UTC
Earlier updates
Monitoring

We are continuing to investigate the issue affecting metrics and log visibility in the dashboard. Users may still experience metrics not loading or appearing delayed.

We have identified high read load on our logging and metrics system as the root cause. Log queries in particular were generating significant pressure on the system, and we have deployed additional rate limiting to reduce this load. Metrics and logs are currently loading, though we are continuing to monitor closely before resolving the incident.

We will provide a further update shortly.

June 8, 16:33 UTC
Identified

We are continuing to investigate the issue affecting metrics visibility in the dashboard. We have identified high query load on our logging and metrics system as the contributing factor and have implemented interim mitigations to reduce pressure.

We are in the process of rolling out a fix and will provide updates as progress continues.

June 8, 14:18 UTC
Investigating

We are aware of an issue affecting metrics and log visibility in the dashboard. Users may experience metrics not loading or appearing delayed.

We are actively investigating and will provide updates as we learn more.

June 8, 13:13 UTC