Metrics and logs may be delayed or fail to load for some users
Degraded Performance
MetricsLogs
ResolvedLATEST

We have seen sustained recovery and normal latency.

This incident has been resolved.

May 15, 14:52 UTC
Earlier updates
Monitoring

We are seeing recovery and are monitoring the results. Metric and log request times should be at normal latency

May 15, 14:38 UTC
Identified

We have identified the issue and are working towards a fix.

May 15, 14:22 UTC
Investigating

We are currently investigating this incident

May 15, 14:11 UTC