Railway - Potential upstream GitHub issue with "Failed to clone" for small subset of builds. We're looking into it – Incident details

Logs experiencing partial outage

Potential upstream GitHub issue with "Failed to clone" for small subset of builds. We're looking into it

Resolved
Partial outage
Started 10 months agoLasted about 4 hours

Affected

Builds (Legacy)

Partial outage from 5:43 PM to 8:03 PM, Degraded performance from 8:03 PM to 9:27 PM, Operational from 9:27 PM to 9:50 PM

Build Machines (GCP)

Partial outage from 5:43 PM to 8:03 PM, Degraded performance from 8:03 PM to 9:27 PM, Operational from 9:27 PM to 9:50 PM

Updates
  • Resolved
    Resolved
    We've deployed a permanent fix and consider the issue resolved.
  • Monitoring
    Monitoring
    We have rolled out a temporary fix and are working on a permanent one.
  • Update
    Update
    We continue to investigate the incident. It occurs on a very small % of builds and retries resolve
  • Investigating
    Investigating
    Potential upstream GitHub issue with "Failed to clone" for small subset of builds. We're looking into it