Scheduled for March 11, 2026 at 11:00 AM – 1:15 PM
Affects
Deployments (Railway Metal)
Under maintenance from 11:00 AM to 1:15 PM
Completed
March 11, 2026 at 1:15 PMCompleted
March 11, 2026 at 1:15 PMMaintenance has completed successfully.
Update
March 11, 2026 at 12:49 PMUpdate
March 11, 2026 at 12:49 PMWe've completed all phases of our maintenance, and are monitoring for any impact before closing out.
Trial users may see their deploy queued for a few minutes
Update
March 11, 2026 at 12:08 PMUpdate
March 11, 2026 at 12:08 PMWe are moving on to Phase 3. There may be some impact to builds, which we will call here if needed.
Update
March 11, 2026 at 11:48 AMUpdate
March 11, 2026 at 11:48 AMPhase 1 has completed successfully. We are moving on with Phase 2, and will report any downtime here. We expect operations to keep running smoothly.
In progress
March 11, 2026 at 11:03 AMIn progress
March 11, 2026 at 11:03 AMMaintenance is now in progress.
Planned
March 11, 2026 at 11:00 AMPlanned
March 11, 2026 at 11:00 AMBackground:
Recent growth in platform usage (9,000+ new users daily) has resulted in temporary queue overload during peak hours on two occasions. While Pro and Enterprise customers maintained deployment capability during these incidents, Trial and Hobby tier users experienced delays in build deployments. To prevent future occurrences and improve overall platform stability, we are implementing infrastructure improvements to our queue system.
Expected Impact:
We do not anticipate any service interruption during this maintenance window. However, out of an abundance of caution, please be aware that if any impact is observed, the following asynchronous actions may experience delays:
- Build deployments
- Staged changes
- Platform configuration updates
Mitigation:
This maintenance is scheduled during off-peak hours (11 AM – 2 PM GMT) to minimize user impact. We will monitor the upgrade closely and provide real-time updates if any issues arise.
Next Steps:
We will post a follow-up update upon completion of this maintenance window. Thank you for your patience as we continue to improve the Railway platform.
For more information, or questions please see: https://station.railway.com/community/maintenance-window-queued-actions-upgr-b3473601