Railway - Deployments may fail to go out – Incident details

Deployments may fail to go out

Resolved
Partial outage 60 %
Started 9 days agoLasted about 1 hour

Affected

Deployments (Railway Metal)

Partial outage from 3:26 PM to 4:24 PM, Degraded performance from 4:24 PM to 4:26 PM, Operational from 4:26 PM to 4:33 PM

US West (Metal / California, USA)

Partial outage from 3:26 PM to 4:24 PM, Degraded performance from 4:24 PM to 4:26 PM, Operational from 4:26 PM to 4:33 PM

US East (Metal / Virginia, USA)

Partial outage from 3:26 PM to 4:24 PM, Degraded performance from 4:24 PM to 4:26 PM, Operational from 4:26 PM to 4:33 PM

EU West (Metal / Amsterdam, Netherlands)

Partial outage from 3:26 PM to 4:24 PM, Degraded performance from 4:24 PM to 4:26 PM, Operational from 4:26 PM to 4:33 PM

Southeast Asia (Metal / SIngapore)

Partial outage from 3:26 PM to 4:24 PM, Degraded performance from 4:24 PM to 4:26 PM, Operational from 4:26 PM to 4:33 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Update
    Update

    We are seeing recovery, and have re-enabled Free, Trial and Hobby deploys.

  • Monitoring
    Monitoring

    We are seeing recovery for deployments. We are continuing to work on a fix for the TCP Proxy: https://status.railway.com/cmmje4pz104ljtr9sh6j30ij9

  • Update
    Update

    A fix has been pushed and is pending rollout. We're seeing issues with TCP proxy connections, related to this incident.

  • Update
    Update

    We are continuing to work on a fix for this incident. New deploys for the hobby, free and trial plans have been paused until a fix is deployed.

  • Identified
    Identified

    We have identified the root cause of the issue and are working on a fix.

  • Investigating
    Investigating

    We're investigating an issue causing a large portion of deployments to error, causing slowdowns across deployments and builds.