Railway - Dashboard slow to load – Incident details

Dashboard slow to load

Resolved
Degraded performance
Started 1 day agoLasted about 1 hour

Affected

Dashboard (railway.com)

Degraded performance from 6:18 PM to 7:16 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have deployed a fix for the dashboard slowness and are monitoring to confirm full recovery.

  • Identified
    Identified

    We have identified the cause of the dashboard slowness and are working on a fix. Users may continue to experience slower than normal load times while the fix is deployed.

  • Investigating
    Investigating

    We are aware of slower than normal load times on the dashboard. Users may experience delays when navigating railway.com.

    We are actively investigating and will provide updates as we learn more.