Railway - Slow build and deployment times – Incident details

Slow build and deployment times

Resolved
Degraded performance
Started about 22 hours agoLasted about 2 hours

Affected

Builds (Railway Metal)

Degraded performance from 5:38 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

Image Registry (Metal)

Degraded performance from 5:38 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

Build Machines (Metal)

Degraded performance from 5:38 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

Deployments (Railway Metal)

Operational from 5:38 PM to 6:48 PM, Degraded performance from 6:48 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

US West (Metal / California, USA)

Operational from 5:38 PM to 6:48 PM, Degraded performance from 6:48 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

US East (Metal / Virginia, USA)

Operational from 5:38 PM to 6:48 PM, Degraded performance from 6:48 PM to 7:10 PM, Operational from 7:10 PM to 7:21 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Dashboard load times have returned to normal. We are continuing to monitor to ensure stability.

  • Update
    Update

    We have rolled out a fix and users should begin seeing improvement in build and deployment times.

  • Update
    Update

    Slow build times are now also affecting deployments across all regions. Users may experience builds and deployments taking longer to complete.

    We have identified the issue and are working on a fix.

  • Identified
    Identified

    Build times are improving and we are continuing to address the underlying issue.

  • Investigating
    Investigating

    We are aware of slower than normal build times in the EU West (Amsterdam) region. Users may experience builds taking longer to complete.

    We are actively investigating and will provide updates as we learn more.