Railway - Builds and deployments are slow to progress. – Incident details

Builds and deployments are slow to progress.

Resolved
Degraded performance
Started about 7 hours agoLasted about 3 hours

Affected

Builds (Railway Metal)

Degraded performance from 6:16 PM to 9:15 PM

Build Machines (Metal)

Degraded performance from 6:16 PM to 9:15 PM

Deployments (Railway Metal)

Major outage from 6:16 PM to 6:31 PM, Degraded performance from 6:31 PM to 9:15 PM

US West (Metal / California, USA)

Major outage from 6:16 PM to 6:31 PM, Degraded performance from 6:31 PM to 9:15 PM

US East (Metal / Virginia, USA)

Major outage from 6:16 PM to 6:31 PM, Degraded performance from 6:31 PM to 9:15 PM

EU West (Metal / Amsterdam, Netherlands)

Major outage from 6:16 PM to 6:31 PM, Degraded performance from 6:31 PM to 9:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Update
    Update

    We are continuing to work on a fix for this incident.

    Builds and deployments for Free and Trial have been re-enabled, and the backlog is continuing to progress.

  • Update
    Update

    We are continuing to work on a fix for this incident.

    Hobby builds have been re-enabled.

  • Update
    Update

    We are continuing to work on a fix for this incident.

    Hobby builds and deployments are paused to help clear the backlog.

  • Update
    Update

    We have released a fix and are currently working through a backlog of queued builds and deployments.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We are currently investigating this incident.

    While we investigate, we have paused builds for Free and Trial users.