Railway - DNS resolution is failing for some domains. – Incident details

DNS resolution is failing for some domains.

Resolved
Degraded performance
Started 3 days agoLasted about 6 hours

Affected

Edge Network (Railway Metal)

Degraded performance from 6:24 PM to 6:30 PM, Operational from 6:30 PM to 12:25 AM

US West (Metal / California, USA)

Degraded performance from 6:24 PM to 6:30 PM, Operational from 6:30 PM to 12:25 AM

US East (Metal / Virginia, USA)

Degraded performance from 6:24 PM to 6:30 PM, Operational from 6:30 PM to 12:25 AM

EU West (Metal / Amsterdam, Netherlands)

Degraded performance from 6:24 PM to 6:30 PM, Operational from 6:30 PM to 12:25 AM

Southeast Asia (Metal / Singapore)

Degraded performance from 6:24 PM to 6:30 PM, Operational from 6:30 PM to 12:25 AM

Updates
  • Resolved
    Resolved
  • Update
    Update

    We are seeing full recovery for all Railway domains since 18:30 UTC. Cloudflare has indicated there should be no further impact, and we are continuing to monitor.

  • Update
    Update

    Cloudflare has identified an issue affecting DNS connectivity.

    https://www.cloudflarestatus.com/incidents/kwy3dt82bwbt

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating
    We are currently investigating this incident.