Railway - GitHub logins or deployments may timeout due to downstream rate limits. We are working on long term resolution for our customers. – Incident details

GitHub logins or deployments may timeout due to downstream rate limits. We are working on long term resolution for our customers.

Identified
Degraded performance
Started about 4 hours ago

Affected

External / Third-Party Integrations

Degraded performance from 6:02 PM to 9:20 PM, Under maintenance from 9:20 PM to 12:00 AM

GitHub

Degraded performance from 6:02 PM to 9:20 PM, Under maintenance from 9:20 PM to 12:00 AM

Updates
  • Update
    Update
    We have temporarily disabled GitHub logins while we work to reduce load on the GH downstream endpoints to regain quota.
  • Update
    Update
    Customers report recovery in most GH operations, waiting to merge long term fixes until resolving the incident.
  • Identified
    Identified
    We are implementing workarounds to increase GH throughput to prevent GH ratelimiting.
  • Investigating
    Investigating
    GitHub logins or deployments may timeout due to downstream rate limits. We are working on long term resolution for our customers.