Railway - Deploys and configuration changes delayed – Incident details

Deploys and configuration changes delayed

Resolved
Major outage
Started about 2 hours agoLasted about 2 hours

Affected

Dashboard (railway.com)

Degraded performance from 10:56 PM to 12:35 AM, Major outage from 12:35 AM to 12:39 AM, Operational from 12:39 AM to 1:22 AM

Deployments (Railway Metal)

Operational from 10:56 PM to 12:39 AM, Major outage from 12:39 AM to 1:22 AM

US West (Metal / California, USA)

Operational from 10:56 PM to 12:39 AM, Major outage from 12:39 AM to 1:22 AM

US East (Metal / Virginia, USA)

Operational from 10:56 PM to 12:39 AM, Major outage from 12:39 AM to 1:22 AM

EU West (Metal / Amsterdam, Netherlands)

Operational from 10:56 PM to 12:39 AM, Major outage from 12:39 AM to 1:22 AM

Southeast Asia (Metal / SIngapore)

Operational from 10:56 PM to 12:39 AM, Major outage from 12:39 AM to 1:22 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We apologize for the service disruption. A post-mortem of this incident will be published shortly.

  • Update
    Update

    Free and Trial deployments have been re-enabled.

  • Monitoring
    Monitoring

    Recovery is underway. Pro and Hobby deploys have been restored. Free and Trial deploys will be re-enabled shortly.

  • Update
    Update

    Our task queue is experiencing an outage. The following operations may fail or be significantly delayed:

    • Builds and deployments (may appear stuck on "Initializing")

    • Service setting changes (e.g., updating environment variables)

    • Environment creation and deployment removals

    We're actively working on a fix and will provide updates shortly.

  • Update
    Update

    The dashboard is now fully operational. We are continuning to work on a fix for significant delay in deployments.

  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Update
    Update

    We are continuing to work on a fix for this incident.

    Free, Trial, and Hobby deployments remain paused, and Pro deploys are delayed.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

    Free, Trial, and Hobby deployments remain paused.

  • Update
    Update

    We are pausing deploys for Free, Trial, and Hobby. Pro deploys will continue, albeit slowly.

  • Investigating
    Investigating
    We are currently investigating this incident.