Railway - Builds are slow to start – Incident details

Builds are slow to start

Resolved
Degraded performance
Started 2 days agoLasted about 2 hours

Affected

Dashboard (railway.com)

Operational from 4:31 PM to 5:58 PM, Degraded performance from 5:58 PM to 6:59 PM

Builds (Railway Metal)

Degraded performance from 4:31 PM to 6:59 PM

Build Machines (Metal)

Degraded performance from 4:31 PM to 6:59 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result.

    Hobby deploys are re-enabled, while Free plan deploys remain disabled.

  • Update
    Update

    We are continuing to work on a fix for this incident. Additionally, we have identified that applying changes may be delayed.

  • Update
    Update
    We are continuing to work on a fix for this incident.
  • Identified
    Identified

    We are continuing to work on a fix for this incident. Slow builds are now isolated to the EU-West region.

  • Investigating
    Investigating

    We are investigating delayed builds in all regions. Builds for free users are paused.