Railway - Private networks were experiencing a degradation causing DNS discovery issues – Incident details

Private networks were experiencing a degradation causing DNS discovery issues

Resolved
Degraded performance
Started about 5 hours agoLasted 10 minutes

Affected

Private Networking

Degraded performance from 12:46 AM to 12:56 AM

DNS

Degraded performance from 12:46 AM to 12:56 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We rolled back the changes and are monitoring for recovery.

  • Identified
    Identified

    The DNS service was returning both IPv4 and IPv6 records for private networks where only one IP version is supported, resulting in connection failures.

  • Investigating
    Investigating

    Users may have observed connectivity issues between their services