Railway - Some users are failing to login. We're looking into it – Incident details

Some users are failing to login. We're looking into it

Resolved
Degraded performance
Started about 21 hours agoLasted about 5 hours

Affected

Dashboard (railway.com)

Operational from 4:08 PM to 5:26 PM, Degraded performance from 5:26 PM to 5:49 PM, Operational from 5:49 PM to 6:41 PM, Degraded performance from 6:41 PM to 8:16 PM, Operational from 8:16 PM to 8:57 PM

Updates
  • Postmortem
    Postmortem
  • Resolved
    Resolved
    We've resolved the issue and put mitigation in place. We will issue a post mortem today.
  • Monitoring
    Monitoring
    Logins should be recovered. We are monitoring.
  • Update
    Update
    We are still working on this issue.
  • Identified
    Identified

    It appears GitHub has rate limited initial logins again. We have re-escalated.

  • Resolved
    Resolved
    Looking good after monitoring. Resolved
  • Monitoring
    Monitoring
    Logins should be recovered. We are monitoring.
  • Identified
    Identified
    GitHub is rate limiting some secondary sign ins. We're rolling out mitigation strategies and escalating upstream
  • Investigating
    Investigating
    Some users are failing to login. We're looking into it