Railway - Deployments are slow to go out – Incident details
All systems operational
Deployments are slow to go out
Resolved
Degraded performance
Started over 1 year agoLasted about 2 hours
Affected
Deployments (Legacy)
Updates
Resolved
Resolved
This incident has been resolved. If your build/deploy has failed during this time, please trigger a re-deploy. Build traffic that landed on the unhealthy registry was dropped and therefore a rebuild is required for these deployments.
Monitoring
Monitoring
We've resolved the issue. A subset of registries restarted, but did not come back healthy, resulting in a subset of pushes failing. These were retried, but with caching, they would be continually fed to the dead registries.